Library

USB connection to computer required to update.* Requires FSX v3.1.0 or greater to operate *Supports GCQuad Putting | FSX2018 paid software upgrade required for FSX putting integration.

Resource Type:
  Firmware

The latest firmware for the GC2 Smart Camera System (all models).

Resource Type:
  Firmware